Wednesday, May 16, 2012

svn+ssh svnserve: command not found on ix2 storCenter

Disclaimer: I'm not much of a Linux guy.

Yet, I've been tasked with setting up several subversion repositories on an Iomega ix2 storCenter; wherein there has to be a layer of security. svn+ssh seemed the easiest path. Now I'm stuck arguing amongst myselves as to how I can successfully check out locally using svn, but not svn+ssh. I see this:

user@ix2-200-TIIU4H:/testCheckout# svn co svn+ssh://user@localhost/var/svn/repos/target
user@localhost's password:
sh: svnserve: command not found
svn: To better debug SSH connection problems, remove the -q option from 'ssh' in the [tunnels] section of your Subversion configuration file.
svn: Network connection closed unexpectedly

The first thing I did was find how to install subversion on this device. The device comes with a read only install partition. So, anything you want to install has to be installed elsewhere.

I've worked from several tutorials that all got me to this same result:

I have gone so far as to copy and paste every line from these tutorials to ensure I wasn't missing a step.

"the Subversion client is not connecting to a running svnserve daemon.
This method of access doesn't require a daemon, nor does it notice one
if present. It relies wholly on the ability of ssh to spawn a
temporary svnserve process, which then terminates when the network
connection is closed."

This tells me ssh doesn't know where to locate svnserve. Assuming ssh actually knows to spawn a temporary svnserve process, how do I tell ssh where svnserve is located?

Also, every time I log back into the machine, my group 'subversion' is gone...

Unfortunately I don't know enough about this problem to explain any better. My apologies. Please ask for clarifications.

No comments:

Post a Comment